Opened 2 years ago

Closed 2 years ago

#844 closed defect (fixed)

configure: locate: invalid option -- n on MacOS X

Reported by: adeiana Owned by: simko
Priority: minor Milestone:
Component: *installation* Version:
Keywords: Cc:

Description

When running the configure script, we can see this error:

checking for OpenOffice.org Python binary... locate: invalid option -- n
Usage: locate [-d path | --database=path] [-e | -E | --[non-]existing]

[-i | --ignore-case] [-w | --wholename] [-b | --basename]
[--limit=N | -l N] [-S | --statistics] [-0 | --null] [-c | --count]
[-P | -H | --nofollow] [-L | --follow] [-m | --mmap ] [ -s | --stdio ]
[-A | --all] [-p | --print] [-r | --regex ] [--regextype=TYPE]
[--max-database-age D] [--version] [--help]
pattern...

It seems the option -n is named --limit on MacOS.

Change History (3)

comment:1 Changed 2 years ago by simko

  • Owner set to simko
  • Status changed from new to assigned

comment:2 Changed 2 years ago by simko

  • Status changed from assigned to in_work

comment:3 Changed 2 years ago by Tibor Simko <tibor.simko@…>

  • Resolution set to fixed
  • Status changed from in_work to closed

In [93a082ea6c671c584089b902817bf6f97374a5b8]:

installation: fix 'locate' call

  • Use 'locate -l' instead of 'locate -N' for Mac OS compatibility. (closes #844)
Note: See TracTickets for help on using tickets.